2.3.2 Update only shows black to other users in MS Teams

Even though my preview shows correctly, including in Teams itself, other Teams users only see a black screen for my video feed.

Teams is where I live, so this has rendered XSplit unusable for now.
This issue arose immediately after updating VCam.


Hello! Does this issue do not happen when using regular webcam in Teams? Can you provide us screenshot of what you see on your end and what your viewers see?

When I uninstalled VCam, the problem went away. Simply selecting the Logitech camera directly was not sufficient; VCam had to be removed from my system.

Once I uninstalled VCam completely, my video feed started to show up for others, though it was still sometimes freezing.

My suspicion is that this black-screen problem is actually some variety of frame-freeze, as Teams has been freezing video quite often for our entire organization, lately.

With VCam installed, I was getting 100% reliable black screens for other viewers, even though it was fine in the VCam preview and in the view of my camera feed in Teams itself.

I don’t have a screenshot, but viewers did show me what they were seeing, which was an empty black rectangle where my video feed was supposed to be.

No watermark, no noise, nothing but empty black where my feed should be. I don’t think you need a screenshot to understand what it looked like :slight_smile:

I didn’t have the problem with Discord, but when I had XSplit Presenter installed, Discord couldn’t show my video at all. After uninstalling presenter, Discord was fixed.

The previous version of VCam was extremely reliable, and I never had problems in Teams, or Discord, or Chime, or Zoom, or WebX. The only issue was that it would show the logo for a long time on first connect, even though I pay to not have a logo.

Now, I cannot have it installed at all.

1 Like

I have also been having the same issue using zoom, videopro, obs and an online teaching platform I use. Everything worked fine until the last update.

1 Like

I have the same problem with the newest version of VCam. Ever since I installed it, I haven’t been able to utilize it with any conference tools that I’ve used - Zoom, MS Teams and Skype.

It’s the same as what the person above stated - I can see a correct camera view in the VCam window, but the image is not sent to the other application, like Zoom, where the screen remains fully black (uniform black, neither the image of me nor the background is transferred).

If I switch off the VCam app, I can use my camera normally in an external application. I believe that the fact the user above couldn’t use the regular view in MS Teams before uninstalling VCam was that it can only be directly used by one application at a time, as per “the camera is already used by another application” messages on my computer. Maybe he/she had Xsplit Vcam minimized into tray, so it still blocked the regular view of the cam in the conference tool.

What I have also noticed is that the installer on your VCam page mentions Windows 10. I have Windows 7 and I am not planning to switch. Maybe the people above also have the older OS. If that is the reason for problems, I would like to be able to use the older version for my license, still hoping you’d make it work for Windows 7 in the future too. I found a link from a mod to an older version of the program in this section (XVC_Installer_1.2.2004.2201) and it works as intended, but I would like to ask you to provide a link to the penultimate version of VCam too. I think it is a great tool, but I cannot use it anymore after the last update.

hi, is there any workaround for this? I just installed vCam and noticed this same issue in Teams. Wish I knew this before I paid for it :frowning:

For me, the problem went away “by itself”.
That is to say after three things had happened:

  1. VCam had multiple updates
  2. Teams had an update
  3. Teams performance issues were fixed
    It seems like the problem is related to scenarios where Teams is struggling. We were suffering poor performance and problems in Teams generally, but intermittent, and variable. MS did something to resolve this, and once Teams was working smoothly again without VCam, I tried reinstalling it with the latest version. Everything was fine.

It’s possible the problem is related to some internal time-limit in VCam; and Teams doesn’t respond (or act) within some limit, causing the VCam feed to be treated as dead by Teams.

Given that so much had changed, both in terms of updates to all products, and a general change in what was happening with Teams, it’s hard to say exactly where the problem lay…