3ds capture GAME CAPTURE within xsplit

Ive used 3ds capture’s software for years and today is the first day it doesnt work any more under “GAME CAPTURE” to add it. i have to add it only as a window now. this is all because i got the VERY NEWEST update today.

How can game capture come back into working?

We’ll need to clarify: What specific app or window are you using as a game capture source in XSplit Broadcaster? If that’s a 3DS emulator or capture software, check if it has any settings for rendering in DirectX (9 to 12) or OpenGL – that would be required for it to show as a game capture source.

I used 3ds capture websites software to play 3ds games with a real 3ds unit. Xsplit allowed “game capture” to find it for 7 years but the very new update of xsplit has killed that. How would I change direct x stuff within xsplit to recognize the 3ds software?

We’ll have to try and replicate that setup on our end, please provide a link for the 3DS Capture app.

3dscapture dot Com then just click software.

Just tried testing it here with the current version, and it’s detecting 3DS Capture as a game source:
image
This was done using the current Version 4.1.2104.2312 downloadable from our site. Which version number are you currently running?

2104, the same. I forgot to mention tho. That 3ds capture top screen and 3ds capture bottom screen are both listed in the game capture menu for me… But when I click both to add to my scene, they are just empty windows that show nothing. No sound either. Maybe a dx problem? I’ve been playing 3ds lately by showing ppl my desktop window instead of “game capture” since it hadn’t worked since update.

Ignore the 3ds menus shown in my image, because thats just me showing my desktop window of the 3ds under screen capture…

however, notice how both screens 3dsCaptureBottom(DX8) (and Top) show up… but the BLUE SQUARE OUTLINE in my image does not pick up the feed of the game anymore since the newest xsplit update. the Blue outline is me adding 3ds capture Top (DX8)… its 100% empty, no sound either. refreshing does nothing. it should have showed the 3ds menus as u are seeing from a regular screen capture.

Yes, the problem is definitely due to DirectX. The 3DS Capture app shows that it’s running DX8, but XSplit Broadcaster’s game capture source Detects DirectX 9 to 12.

If my computer didn’t change but xsplit did, what should I change if anything?

You can try using Window Capture for the 3DS Capture window instead:
image