Add browser as source

Hi,

I just switched from OBS to Xsplit.
In OBS, I always used a “Window Capture” source to capture my browser (Chrome). However, in Xsplit it seems that I can only choose a specific Chrome tab as a window source and not the whole browser. This is an issue, because when I go to another url, the capture just shows black.

How can I add my browser as a source please?

Thanks!

Hi! The Screen capture source has a few different options you can use.

  • Smart Selection for choosing a specific region of a window or screen.
  • Monitor Capture for selecting an entire desktop screen.
  • Window Capture for selecting a specific window, which should allow you to choose just the browser itself rather than a specific tab.

Alternatively, Webpage sources can use a specific URL as a source.

Can you send us a screenshot of how it’s limited your options to just a specific Chrome browser tab?

Thanks for the help :slight_smile:

In the settings of the Window Capture, I can’t see the whole browser in the list. I can only see tabs. When I choose a tab, it works, but as soon as I change tabs it shows me a black screen.

I can’t post links and I can’t upload images, so I’m afraid it’s kinda hard to show you my screenshot.

Could you check if you have hardware acceleration enabled on your Chrome Advanced settings? If yes, can you test having this disabled then try using screen capture once more and see if it would still show black

That doesn’t seem to make a difference, sadly. Hardware acceleration was already disabled.

xsplit-window

Would it be possible for you to create a quick recording showing the steps you do on your end to replicate the issue? You can reach out to us with the link on our chat support here https://www.xsplit.com/support

It works now! I removed the window source and re-added it, and everything works as expected now :slight_smile: Thanks!

That is great to know that it is now working on your end!