Add Scene Background to fit whole screen for main scene

Having trouble with background scene under Scene Properties. Wont’t stretch to fill screen. Used 1920x1080 jpeg and png images. For example, have a Master Chief image as background while I have a smaller window that shows me streaming Halo game. Some streamers do that, showing a background image of a game that they are streaming.

Hi there, can you provide screenshot of your XSplit Broadcaster window showing the sources added?

And, can you right click on the source then on source properties go to the Layout tab and uncheck keep aspect ratio.

Hi, using Gamecaster and here are the screenshots of what I mean. The second screenshot below shows it correctly. But when I go stream live it doesn’t show that. I drew a red circle around the issue.


It’s a 1920x1080 jpeg. Funny thing is, a random image, 2560 x 1440, worked fine. But it’s hard to find background images I want in that resolution. Was hoping for 1920 x 1080. Thanks.

@undefeatedchamp23 Going to sound weird but could you try something for me? Set your display to 100% for Scale and Layout in Windows. Let me know if this fixes it. As long as the image is 16:9 and looks correct in the editor then it should look correct in the main scene.