Advertisement in paid version

VCam displays the VCam logo and url to video conferencing participants while the camera connection is established. This sometimes takes up to 5 seconds.

Please disable and show only a black screen during this time. I’ve paid for the full version and was expecting all watermarking and advertisements to be gone from the video feed.

I believe this has been requested and is currently the 2nd most upvoted item here -

Yes, it has been requested a year ago. Changing it to a black screen would be a trivial code change. However, that hasn’t happened.

It’s not a program that can be used in a professional setting.

Hi @claus-xsplit, this is currently in development and will be included in a future update soon.

Hi I just downloaded and installed VCam, and bought a three month subscription. Seems to work great, but I have the same issue. I can’t have that logo displayed when I enter a conference. I’ve requested a refund. Hopefully the developers read this board and can make this simple change.

Cheers, thanks, and stay safe

I just need the autologin for xsplit vcam enabled. Starting without login results in watermarks - not acceptable.
Many thanks for your help,
kind regards

Uwe, we’re talking about a different issue. While XSplit VCam initializes the webcam the following is displayed to other people even if you are logged in:

Hi @ole.eichhorn, we’re currently working on this issue, and hoping to add a fix/improvement in the next update release.

Hi @uwe, autologin for xsplit vcam enabled - Do you mean you always need to login when starting VCam?

Hi @claus-xsplit, Skype for Business as well as Skype from the Microsoft Windows Store is currently not supported.

Excellent glad to hear, and look forward to trying that version. I’m sure you’ll post here when it’s available and then we’ll all be notified.

Cheers, thanks, and stay safe

1 Like

OK, here’s the Zoom screen shot if that makes a difference (not from my experience :slight_smile:)

My primary use was WebEx and Microsoft Teams, both which aren’t supported either. They work fine with VCam but I stopped using it quite quickly due to this issue. People made fun of me that I paid money for something that shows advertisement. Truth to be told I agree with them. And it’s not professional since I got it for work. I’m looking forward to the fix and hope not to have to request a refund.

Zoom has it’s own build virtual background which works great and thus there is no need for VCam.

yes that is my concern. That results in watermarks (unpaid version) as long as I login manualy.
Is there a fix for ?

Hi @uwe, you have the same issue here : Login Every time. I’ve tagged you there for the steps.

Just a friendly reminder to everyone that it would be 100% against the XSplit terms of service to use a DLL editor like ResourceHacker to replace their logo within VCamSrc.dll with a black image. It’s 100% not OK, and you should wait another year instead while they “work on” this patch.

Hello all,

We’re actively working on this - to provide a way to disable the logo splash screen. We ran into some issues during QA for this and are working to fix them asap.

Hello all,

We’ve just pushed a front-end update that allows you to remove the splash screen (logo screen when VCam is activated in another app). Note that this option can be enabled for an XSplit account with upgraded license.

Installing or restarting the latest version 1.2.2004.2201 should apply the new front-end version 1.2.2004.2701.

To enable this, go to main menu and click “Remove splash screen”. After enabling, remember to restart the application using VCam to apply the new setting.


@cheesyrambo Works great. Pass on my thanks to the developers.

1 Like