Blue screen with latter versions

Recently I tried installing the latest beta and it blue screened with “Page fault in non-paged area” with XSplitVid.sys listed as the culprit. Attempt to run the uninstaller results in

“Windows cannot find ‘C:\ProgramData\Caphyon\Advanced Installer{DA35B7ES-F7FE-4F4E-8E4D-32F73F4217C0}\XVC_Installer_2.0.2008.2201.exe’. Make sure you typed the name correctly, and then try again.”

I --think-- 1.2.2004.2201 was the last version I was successfully running.
I believe 2.0.2008.2201 may have been the release I last tried installing (unsuccessfully).
2.0.2007.0203 was the most recent attempt.

Any idea what I need to do to get things cleaned up?

Windows 10 Pro
Alienware AURORA_R4
Intel® Core™ i7-4930K CPU @ 3.40GHz 3.40 GHz
32.0 GB RAM
64-bit OS, X64-based processor

Update:
Tried manually removing everything. Folder/files/registry entries. Tried installing 2.0.2008.2201 and got this:
“The older version of XSplit VCam cannot be removed. Contact your technical support group.”

Hi there, since you still get notification The older version of XSplit VCam cannot be removed. Contact your technical support group during installation of new version it is still possible that left over files or your PC still thinks that it is installed.

When you go to add/remove program in your control panel do you see XSplit VCam there? Can you try this Microsoft troubleshooter that can be used to fix issue with installation or uninstalling programs.

For more details how it works go here: https://support.microsoft.com/en-ph/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed

Then download the troubleshooter here

No. XSplit VCam is not present in the add/remove program list.

I ran the trouble shooter. I did seem to flag an issue but it did not fix it.

image

Is it the XSplit installer/uninstaller that is detecting another VCam install? If so, where (and what) does it look at to determine that?

We’ll have the devs look into that crash. Please send us a photo or screenshot of the blue screen itself, and also generate a crash dump file through the following steps:

  1. Download this file: https://cdn2.xsplit.com/download/common/utils/XSplit-LocalDump-AutoGenerate.zip
  2. Extract the .zip file and run: XSplit.Core.exe-AddToLocalDumps-%localappdata%.reg
  3. Restart XSplit Broadcaster and repeat the crash (this is also where you should get a photo of the blue screen).
  4. This should generate a log in this directory: %localappdata%\CrashDumps
  5. Compress the .dmp file then send that to us via Dropbox or Google Drive.
  6. After that, run XSplit.Broadcaster.exe-RemoveFromLocalDumps.reg (also from the .zip file we sent) to disable the automatic generation.

I don’t have Broadcaster. Xsplit VCam only.
At this point, I’m not going to get far enough into the install to get the XSplitVid blue screen (towards the end of the install). Currently the installer stops very early with “The older version of XSplit VCam cannot be removed.”. I’m guessing some of the files what would remove can’t be found. I suspect, at this point, I will have to manually remove everything and start fresh.

  1. What did the installer find that triggered “The older version of XSplit VCam cannot be removed.”?
  2. Do you have a manifest listing all the files and directories that get installed? (and drivers if any)

I’m open to any suggestions.

Doh… I missed the link to Revo Uninstaller. Stand by, I’ll try that.

Try using Revo Uninstaller to remove that instead:

https://www.xsplit.com/support/useful-tools/using-revo-uninstaller

Revo Uninstaller did not list anything “XSplit…” or “Splitmedia…”

regedit shows this:

image

Hi @Quick, were you able to successfully run 2.0.2007.0203?

Please try to re-install the last known working version. Running the last known working installer should either create a fresh installation or allow the user to either Repair or Remove the installation.

After that uninstall VCam, then delete “XSplit VCam” key if this still exists in Registry -> Computer\HKEY_LOCAL_MACHINE\SOFTWARE\SplitMediaLabs\XSplit VCam.

Then re-install 2.0. Please let me know how it goes.

Well… some progress :slight_smile: We’re past the “cannot remove…” message and back to the BSOD with XSplitVid towards the end of the install.

The only way I got here was (fortuitously) there is a newer version out (2.0.2008.2502). It asked if I wanted to download and install that. I selected that and it dropped me into a selection to “repair” or “uninstall”. I selected uninstall. That appeared to be successful. Then I did it again and it went into a fresh install (asked for language selection, etc.). That continued until I hit the BSOD again.

Looked in Event Viewer and we have this:
image

That particular file looks like this:
image

(more useful… the whole file – at least what VIM sees)

Also followed instructions from Hamstah_fwend for getting the crashdump.
Nothing generated in %localappdata%\CrashDumps
Nothing generated in %localappdata%\CrashDumps\local

[Update]
I am able to install and run 1.2.2004.2201.
Run the 1.2.2004.2201 installer. It flags a more current installation and I opted to proceed. Then it was unable to remove …something… and I just pressed on. 1.2.2004.2201 appears to work fine (although I may be sitting on a time bomb due to the failure to remove something :)). So it appears my issue is only with the 2.0 installation.

@Quick Apologies for the late reply. Could you check if there’s a crash dump in C:\Windows\Minidump\ and send to us together with your MSINFO? Here is how you can get the MSINFO: https://www.xsplit.com/support/useful-tools/generating-an-msinfo32-file

Sent it to support@xsplit.com
(hope that was the right minidump)

Doh.

image

really? from support? at a company dealing with video? :slight_smile:
The “dmp” file extension? (but it’s the support email box…)

Maybe I can upload it somewhere and you can pick it up from there?

Update: I changed the “dmp” extension to “dmpx” and it looks like it worked

Hmmm. Lots of rejection notices. Got responses from Lorenz though :slight_smile:

I’ll try one more time with just that one file… You don’t have a 4 MB limit on attachments do you (this is the smaller file)?

rejected…

Hi @Quick, Received the msinfo, thanks!

Maybe I can upload it somewhere and you can pick it up from there?

Yes please!