Browser Support for Vivaldi

I do not want to use a browser that does not respect my privacy. Recently when I try to use a link within Broadcaster to show a webpage the page will not load. Instead, I receive and error “Browser No Longer Supported.” Has anyone managed to resolve this? Thx.