Can't turn off Xsplit Vcam background removal when using Microsoft Teams

I have used Xsplit Vcam to remove my background for some webianrs. Now, I no longer want to remove the background for my normal business meeting but face the following issue:

In Microsoft Teams, when I select my webcam as input device (Logitech C920), the background still gets removed.

First, I don’t understand why this happens when I select the camera directly and not Vcam as input.

Second, I now uninstalled Xsplit Vcam and rebooted but this is still happening and I am stuck as I can’t even configure Vcam anymore.

When I start up the Zoom desktop client, Logitech Capture or OBS I can see the original camera image without problems. It is as if Vcam rewired something in Teams that did not get removed when uninstalling it.

Any suggestions appreciated.

Update: After signing out of Teams and signing back in I can finally see the original video again (without background removal).

I am still concerned that Xsplit Vcam was still affecting the video after uninstalling it so any information on what might have happened would be great!

Hi @nils.betzler,

Do you think you may have activated a background in Microsoft Teams? ->

When I logged out then logged in to MS Teams, the background setting in Teams was back to default “No background”.


Really good point. In Teams, I was checking the video camera stream in the Device settings and in a Teams test call. In both of these places, you can’t see or change the settings for the background effects - it just keeps applying the effect that was used in the last call.

The solution is to call a person, then change/turn off the background effect.

So this had nothing to do with Xsplit Vcam, but is rather a lack of better control of background effects in Teams.

Sorry I did not spot this and thank you!

1 Like