Having issues with vcam lag

So i’ve been having an issue recently with Vcam. Basically, any app i use vcam for will drop frames for a bit, smooth out, and repeat. The preview window on Vcam shows no stuttering what so ever and finding info about this info doesn’t exist so I’m calling upon the community to help me out here. :slight_smile:

Hello there!

Thank you for the detailed description of the issue you’re having with VCam. Has this been happening since the first time you installed VCam in your system? It could be an issue with your system resoures, or the GPU drivers. It may also be something that can be fixed by adjusting some settings on VCam, or by simply updating your Windows OS and Graphics card drivers :slight_smile:

But let’s check first, to be sure. Would you mind providing the following information about your system?

  1. Processor
  2. RAM
  3. GPUs (The graphics cards currently installed in your system)

Also, please go to XSplit VCam and click the menu icon at the upper-left corner, then go to Settings. It should show you GPU and quality-related settings to the right pane of the app. Can you please provide a screenshot of this as well?

Thank you!

For my specs I’m running an Intel Xeon E5 CPU with 16GB of RAM along with A NVIDIA GTX 1650. And No it hasn’t happened before hand, only started recently.

https://i.gyazo.com/241e71e83871d849cd0d97dfb2693ba7.png

Alright I understand. Thank you for providing the image! May I know the troubleshooting steps you have done so far? so we can continue from there :slight_smile:

I have tried to change to cpu for hardware accel, reinstalled the software, updated my graphics driver

I’ve also gone and updated to the latest version of windows and that hasn’t worked either

Hello again! Thank you. May we know the camera you’re using? Also, please try the following steps and see if they will work:

  • Try disabling “Enable HD” from VCam’s settings. Let’s see if it’ll yield good results.
  • Also try disabling “Always 30 fps”

Let’s see if one of these 2 settings will improve its performance when added to other apps.

Im using the Logitech C525

I have tried disabling both options. Both don’t seem to work.

Hi! Our devs have recently released an update for XSplit VCam, version number 2.2.2103.2502. It’s not prompted by the in-app update, so you’ll have to uninstall your existing VCam and redownload the installer from here: https://www.xsplit.com/vcam

Try installing this version and see if you’re still having lag problems with your XSplit VCam.