Long boot times & no response

So this only started to happen recently with the last update, but I noticed changes happen one night after a stream. I switched scenes to my “ending soon” and went to end the stream to notice that the program didn’t register any of my button clicks to end stream to scene switching.

Following night I went to boot the program and it takes upwards of 10 minutes to load, and usually tells me the presentation is buggy. After a few hours of headaches I tried to create a new presentation, but even after saving and quitting, to then reboot the program still takes 10 mintues. So it leads me to believe something is going on with the latest program update that I’m unsure what the cause is. I still can’t switch scenes in the off chance I get the program to run and start a stream.

Anyone else having this issue, or know of a fix?

Hi there, may I ask which version of XSplit are you using where you encountered the issue? And, does the issue happen with our with out any sources added on XSplit?

I’m currently using 3.9.1912.1008

It happens both with and without sources.

However, there has been a new thing I noticed. AMD’s newest update for their video cards have mentioned that there is an issue with “switching scenes” in xsplit for people on previous versions of the firmware. After an update XSplit worked flawlessly. MAJOR DOWNSIDE is that the newest version is an unstable release and all new games I tested with it dropped so many frames it was like playing in 12 FPS.

So, after a downgrade to 20.2.2 it’s been acting funny again. I switch the scenes and it seems to work fine for a moment but I couldn’t stop the stream and had to force quit the program. So I guess I’m stuck with it until AMD finally stabilizes the build.

Figured I’d update. I reinstalled the unstable firmware again and after getting the games to run smooth again I tried xsplit, but the problems still persist.

Switch a scene while NOT streaming and everything is right as rain. When I get the stream going and after about a few minutes I click a new scene, or just in general, click anything including the menus and the program seems to hang. It still is sending out data through the stream and such though, however, it takes ages for it to respond.

What info should I upload for you guys to take a look?

1 Like

Could you do a test using PTR version of XSplit Broadcaster which you can get here https://www.xsplit.com/ptr

Same issue exists. I even just tried a downgrade and the issue continued to exist. A part of me still thinks it’s the firmware for the graphics card, so I’m gonna send a dump log to AMD and drop on here in a few before I downgrade the card to something earlier.

So there was a development. I was gonna drop the file here, but last night a different issue happened entirely, but there was a windows update for .net framework which seemed to fix the issues I was having. So everything is as it should be. If things change back I’ll post up the files

Good ol’ windows updates

Of course it happens again.

Hey @dlhunt86 - Before uploading, any chance you could compress/zip the file first? It’ll help massively with the file size and make it easier to download

Oops sorry, here

1 Like

Hi there, apologies for the reply our developers has some steps that would like for you to try as based on the logs you have provided it seems to be due to OS issue. Could you do the following?

  1. Install all OS updates on your PC.
  2. If OS is up to date. revert/remove the latest updates before the started happening.
  3. Run sfc /scannow to check OS files. Here is how: https://support.microsoft.com/en-ph/help/929833/use-the-system-file-checker-tool-to-repair-missing-or-corrupted-system