Long Delay Switching Scenes

When I click on a scene, it takes several seconds to switch. This started happening after a Stream Deck update. However, even if I exit out of the stream deck software and unplug it, the scenes still take forever to switch with a mouse click.

Thanks for your help!

Zach

Hi there, can you do a test where you disable Thumbnail Preview by setting it to never show on scene hover? You can do so on the General tab in Tools > Settings of XSplit Broadcaster

That didn’t change anything.

Sorry to hear that, may I ask what sources are added in XSplit Broadcaster? Could you also provide me screenshot of the Advanced tab and General tab in Tools > Settings of XSplit?

Something to check: Is Keep source in memory enabled for the sources in your scenes?

Memory

I only had it checked on a couple of sources. I went ahead and checked them all. Another thing that’s been happening is that once I start streaming, the video and all the other animations get choppy. It seems okay on the broadcast end, but on my side, it’s rough. Everything was working perfectly and I didn’t change a thing. I guess something got updated to cause all these problems.

Actually, I’m not even streaming now and everything is choppy. So weird. It’s like my CPU is suddenly struggling.

Does it still get choppy if you create a new presentation, then reload your current presentation?
Save Presentation

I’m having the same type of issue, unfortunately.

Does yours also lag if the Thumbnail Preview is disabled in General settings, or if you try saving and reloading the XSplit Broadcaster presentation?

I already disabled the thumbnail preview and it didn’t help. What I learned today during my live stream is that if I re-load my presentation, everything is fine. However, once I hit any button on the Stream Deck, the CPU usage goes through the roof and everything gets choppy. Also, it takes several seconds to switch scenes. This all started after an update by Stream Deck.

The devs are currently looking into some problems between the current versions of both XSplit Broadcaster, and Elgato Stream Deck. We’ll check if there are any findings with the plugin causing any unusually high CPU usage or lag in scene switching.

Does it work normally if you run that with the Stream Deck plugin disabled?

If I don’t use the Stream Deck, everything is fine.

@zach Out of random curiosity, you don’t happen to be using any actions/plugins by BarRaiders do you?

No, I don’t even know about those plugins.

Okay no problem. Was asking because someone else had solved some issues they were having by not using those actions. Anyway, we have an update coming a bit later today that fixes a handful of Stream Deck related issues. If you could try those out and see if the issue still exists, that’d be great.

Will do. However, today, even without my stream deck, it takes a few seconds to change between scenes. Odd. Thanks for the help!

Quick Update. I noticed everything works fine, even with the Stream Deck, except for two issues.

  1. Changing scenes always takes several seconds. This is the case even if the stream deck is unplugged and I’ve quit the app.

  2. The Stream Deck works fine for everything until I hit the button which opens the folder containing all the stingers. If you look at my screen shot, the sources under stingers (circled in red), are the culprit. As long as I don’t do anything with those, everything is fine. As soon as I play one, the CPU becomes strained. It’s worse if I use the Stream Deck, but even if it’s not in use, playing one of those causes problems.

Could you see if your sources are kept in memory? If they’re not, the app waits for them to load before completing the scene switch.