Occasional "Freeze" when streaming

With everything looking great while Recording locally, when Streaming there is a Random 1-Second Freeze, only from the Game Capture Device (Audio, Webcam, etc are fine). No dropped Frames and Capture Device is running well. V-Sync on and 60fps chosen.

Confirmed Capture Device is running as expected by Recording with XSplit and the Device’s Proprietary Software (RE Central). Streaming also has Zero Stutter when using Twitch Studio with the same settings (720p@60, NVENC, 2 Key Frame Interval, 5000kbps)

GPU and CPU are not Taxed during Encoding. Have used all suggested Encoding options from the Support Site for GPU NVENC (GTX 1050 ti) and tried lowering everything down to as low as it can go and it still stutters when streaming. Any assistance is appreciated.

Hi! To clarify a bit more: Which AVerMedia capture card are you using?

Please also send us screenshots of your local recording and stream properties from XSplit Broadcaster, for comparison. Also let us know the result it shows you for Upload Speed in: https://www.testmy.net/upload

We’ll need those to check what should be adjusted in the stream settings.

Batolomew,

  1. Capture Card: AverMedia Portable Gamer 2 Plus

  2. Here’s Upload Speed from WiFi on a Mesh Network while my kids are streaming:


    (My Streaming Laptop is Hardwired and I’ve configured QoS for Twitch…but even this more than accounts for plenty of headroom for 5000kbps, and I do not have dropped frames)

  3. Here are my Settings from XSplit:
    Settings1

    Settings3
    Settings4
    Settings5
    (I’ve attempted lower Quality on the GPU Encoding, I’ve attempted lower Resolutions on Broadcast as well as Workspace, I’ve attempted lower FPS, I’ve attempted lower Bitrates as well, down to 2000 and have still experienced the Stutter)

For Examples:
Xsplit Streaming with Stutter issue, 900p@60 5000kbps NVENC and Settings from above - switched to 900p Res from 720p for testing purposes, but the same issue remains
Twitch Studio Streaming, 720p@60 5000kbps NVENC, no Stutter

You can try changing the resolution and frame rate to 720P/60FPS, bit rate to 4500 kbps and check Enable Look Ahead as highlighted in the screenshot below. If that doesn’t work, you can reduce the option of the Encoder Preset to Quality, check if VBV Buffer is also set to 4500 kbps and set Maximum B-Frames to 2 (also seen on the screenshot below).

image