Something went wrong authorizing your account with XSplit

Hi all,
I’ve been using Xsplit vCam for a few weeks now but since updating to the latest version I keep being asked to login so I can use the lifetime license that I have purchased and remove the watermark from my videos (I’ve seen similar threads on here around this too but nothing helped) but the issue I’m facing now is that I’m unable to login to the app and just get the following error screen regardless of login method (tailored service messages but same error).

If it helps, I’ve tried the following login methods:

  • List Local username/password
  • Google/YouTube
  • Twitch

The result being that it logs me successfully into the website but no longer logs me into the app which just continues to sit on the waiting to login screen

I’ve uninstalled, deleted directories and reinstalled the app a number of times now and verified it is running the latest version as follows

Any help in getting this to work would be much appreciated.

Hi! This login problem is known to happen due to issues with the System Time. Make sure that yours is synced with the internet time:

Hey Batolomew,
Thanks for the response but my system time is fine and matches up with several online services to the second.

I’ve just tested it across a number of different browsers to make sure there’s no browser specific issue and see the same error across them all. This wouldn’t be a server time issue would it?

When you were testing that across different browsers: Do you have adblocker disabled for all of them? Which specific browsers had you tested so far?

Browsers tested are as follows:

  • Brave (with and without shields + bitdefender disabled)
  • Chrome (adblocker turned off + bitdefender disabled)
  • Edge (no adblocker installed + bitdefender disabled)
  • Firefox (no adblocker installed + bitdefender disabled)
  • Internet Explorer (no adblocker installed + bitdefender disabled)

Bitdefender was disabled both via the browser plugins (where available) and by turning off all the protections in the app itself.

We’ll see if we can spot what’s causing it to not login. Can you send us a screen recording of how it looks starting from VCam’s launch, then attempting to login through the browser window that shows the error message?

Hi Batalomew,
I’ve uploaded a vid to Google Drive, let me know if you need anything else.

Okay, I think I’ve resolved this issue by connecting to a VPN and running through the process again and it went straight through.

Could be an ISP related issue which is weird.

That is odd. If it’s not something directly in the ISP, it may be some firewall settings or possibly a network monitoring app, if you have any of those running.

Yeah that’s what I was wondering but there’s nothing changed in the rest of my setup but it’s working fine at the moment and persisting the session so all is well :slight_smile:

Will do some further digging if it happens again. Thanks for the assist, much appreciated

I have the same issue. Was this resolved somehow?

Same problem, Here is how I resolved it using Brave browser.

  1. Updated to latest xsplit vcam (currently 2.0.2011.1701)
  2. Shut off Brave shield for the xsplit website.
  3. Log out of the xsplit website and close the browser.
  4. Open the Xsplit Vcam app and now logon and it worked.

Hope this helps.

Hi there, with regards to this issue it has been confirmed that it is due to Brave Shield. Would advise disabling this to be able to login using Brave browser

I have a paid subscription and after turning on MFA it is asking for a code generator. I scanned the QR code into Google Auth and it’s not working? I’m no longer able to get into XSplit VCam?

Hi! You can contact the Support team for assistance with that 2FA problem. Please send them an email at: support@xsplit.com