Unable to authorize XSpit to use twitch

When I click “Authorize XSplit to use Twich” in the Twitch properties window, I am unable to complete the process. I get a popup window as expected, however the window closes itself almost immediately after appearing. Sometimes, I can see a flash of the Twitch login window. Other times, it doesn’t last long enough for even that.

This issue has occurred across two PCs (current PC is new and a completely fresh install).

Any assistance would be greatly appreciated. If helpful, I can create a video demonstrating the issue.

1 Like

Hi there! I see… yes, a video would be great! So we have a visual of what’s happening.

Has this been something that’s been happening since you first used XSplit?

Here’s the video:

As to your question, no. It used to work.

Is 2FA enabled for your Twitch login?

It is currently not enabled.

Enable it first, then retry your Twitch login in XSplit Broadcaster – 2FA’s required for Twitch streaming through that.

Where is this requirement documented? When did it change?

You can refer to this page on Twitch for more info about that:


In the article posted above, it says

However, I don’t think your issue is related to having 2FA enabled or not. What happens if you try to connect Twitch through the account page on the website first?


Different result now. I linked ok on the page here. Now, I get a window that stays, and tells me to pick an account. My account is listed. When clicked, I get “Insufficient permissions…” and options to reconnect or continue.

At this point, I assume it is a 2FA issue, now that I can actually get the window to remain.

I’m currently having this same issue but 2FA is enabled on Twitch (and on Xsplit).

When I click “authorize” it shows my account but it says “insufficient permissions”.
When I click “reconnect” it flashes the twitch login and then it immediately closes.

Hi, can you make sure that Twitch plugin is up to date? To do so go to Tools > My Plugins.

And, make sure XSplit Broadcaster is up to date aswell you can check by going to Help > Check for Updates

If issue persists, unlinked your Twitch account first on the Linked Accounts tab here https://www.xsplit.com/user/settings#settings

i think maybe ıts about adblocker just try

My twitch add-on shows up to date. I’ve also tried removing it from my linked accounts in settings.

Neither solution helped.

I also tried disabling my Pi-hole which didn’t help anything either.

Still not working for me :frowning:

Tried removing and reinstalling as well.