Unable to Stream - Error in Gamecaster

Hi to All,
First of all please apologize my terrible english. I wonder if you can support me, as long as it is not a trouble for you.
I have installed XSplit Gamecaster but I get an error when I try to stream to Youtube.
I receive a red popup message at the top right of the window saying “Cannot read property “id” of undefined”.
I have already tried to uninstall and reinstall the software withut any success.
Have you any suggestion about it?
I run it in a Windows 7 Pro client. It is a HP ZBook 17, Xeon as CPU and 16 GB Ram.

Thanks a lot in adavance for any suggestion.


1 Like

Hi there, do you get this error every time? And, may I ask when do you get this error does it happen once you click on Stream? Also, can you provide screenshot of the error

1 Like

Hi Moriones, thanks for your feedback.
When I click on Stream button I get a first error with just the caption “Error”

If I try to fill the fields necessary to stream such as Title and Description and click on the “Go Live” button I get the second error

1 Like

Hi gionnysan! You should see “Stream Now” or a scheduled event inside the first dropdown. Is that showing as completely empty to you?

Hi Jon, Thanks for your reply. Yes I confirm the list of the first dropbox is empty I cannot select anything.

1 Like

Late reply here, sorry! That’s not to be expected and you should always have at least Stream Now show there. I’ll follow up with the team and set something up to be investigated.

Hi, any news on this problem? The same thing is happening for me, too. Dropdown is empty.

Hello, i have the same problem. Any news ? Thanks

Can you go for reauthorizing the service account on Gamecaster?

Here’s a step by step method:

  1. Try unlinking your YouTube/Twitch/Facebook from here: https://www.xsplit.com/user/settings#socials (don’t link it yet)

  2. Then restart your Gamecaster app, and re-authenticate your service login on the app.

hello sorry for my bad English but I had the same problem of Cannot read property “avg” of undefined
all I did to fix it was log out and log in again and it worked
I hope this might help if it works for u guys

Hi! Gamecaster is no longer under the XSplit brand. The current Gamecaster site is at: https://gamecaster.com/

You can reach out to the Gamecaster team via Discord on this channel: Gamecaster