USB Mic echo+ Other audio

Hi! So I recently bought a Samson G track pro microphone, and when I tried to use the microphone; I noticed a terrible echo coming from the local recordings I was doing. I then realized if you mute the audio coming from xsplit then the echo goes away. But by muting the xsplit audio, you cant hear any in game audio or other people talking. Is there a way to have the best of both worlds? Or do I need to switch to a different app.

Hey @JosephRoss411,

Have you added the same microphone as an audio device source? By default, your default microphone is selected as main microphone on the XSplit audio settings. With that pre-selected, you no longer need to add it as an audio source.

If so, remove the microphone audio source on your scene.

1 Like