VCam Background not changing

I have a lifetime license for VCam.

  1. I installed VCam and it worked flawlessly for about 14 days, especially the replacement of backgrounds and the switching from one background to the other. I use several own backgrounds from my directory.
  2. All the backgrounds are in the list/the preview.
  3. Since the beginning of this week, it does not start anymore with my own backgrounds.
    Starting with the Unsplash-Photo or Website or Video works.
  4. Changing the background to “my own” background leaves me with a black background.
  5. funny effect: If I activate one of “my backgrounds” (=result black background) say "add background, go to Unsplash-Background, hover a bit around with the mouse, see the previews, then select “x”, “my background” is there and activated :roll_eyes:

I did not change anything with the ddirectory or the resolution of my own backgrounds.
Any ideas how to solve this? How to reactivate the switch from one background to the other?

Hey @lizenz,

Can we have a sample of your background that is not working and a screenshot of your VCam window?
What’s your version of your VCam? We recommend updating your VCam software to the latest version may help to resolve some of the issues that may encounter.

Hey gigzz15,
thank you for the reply - the version of VCam is front-end 1.2.2004.2201/1.2.2004.2201!
No updates available.
The Screenshot:
screenshot%20Vcam%2020200601
Background sample:

Perhapls you have an idea…,

Okay, I try to replicate and download the sample image and it worked for me. It looks like you have to manually update your XSplit VCam, our updated version is 1.2.2004.2201 and the front-end is 1.2.2005.2601. Try to download from our site and re-intsall VCam.

I deinstalled the current version and reinstalled the latest, downloaded version.
Same effect like described above.
Where does XSplit store its own files? Can it have to do with the path of the own background files?

@lizenz You can try to copy the images to a different folder, then re-add these images VCam and use as background, see if it works now. Do you also have One Drive enabled?

Please collect debuglog too and send it to us so we can forward to our developers. You can follow the steps here: https://www.xsplit.com/gamecaster/troubleshooting/debug-logs

Hi @lizenz, please try our 2.0 Beta version. The background references have been moved to registry and hopefully this solves your issue. It may help to re-add the images as well.

You can get the 2.0 Beta installer here : https://community.xsplit.com/t/vcam-2-0-beta-is-here-2x-improved-ai-hardware-driver-installation-image-and-video-background-configuration

Hi cheesyrambo,
I finally made it!
Installation of Ver. 2 beta did not solve this problem. Still the change of backgrounds could only be done by clicking on the background I want, then “add-backgrund->Unsplash foto->hover over a photo, click"x”" and the background I choose in th efirst step is there.

Solution: I copied all the backgrounds into a subdirectory of user/photos/…"
There seems to be a problem with the path to background photos. Perhaps too long or messed up somewhere?

Thank you for your help!