VCam works in my app but Broadcaster doesn't

Hi,

I have a Unity3D based application that uses the webcam and I can get XSplit VCam to work but not Broadcaster.

All the camera instances show up in the selection list but there is no feed from Broadcaster. It does work in Skype however.

Is there anything different I need to do to get Broadcaster working?

Hi there, may I ask which version of VCam and XSplit Broadcaster are you using at the moment?

The latest stable versions from the web. Not the PTR.

Although I have tried the PTR and the same result

Are you using the PTR version of VCam? Basically VCam PTR implemented its camera as a driver which will allow it to be detected by any app that can pull in webcams. Previously it used a virtual camera method which doesn’t work in all apps. Currently, XSplit Broadcaster is still using the virtual camera method and as such may not work in apps that don’t work well with Virtual Cameras.

I’m using the latest stable version of VCam v1.2.2.

However your explanation would certainly equate to the behavior I’m experiencing.

Are you aware if ManyCam uses the driver model? As this application works.

I’m just not a big fan of the interface of that program.

SplitCam is another one that also works but output resolution is in a fixed state.