When XSplit is open prevents the usage of chat within FiveM

Hey all!

Ran into this issue the other day while playing FiveM. (GTA Modded Multiplayer)
When X-Split is open, the chat is no longer viewable in-game and can only be viewed when tabbed out.

While it’s hard for me to get this on recording here is a GIF of when I am in-game with X-Split open.
The only time the chat appears is when I tab out of the game. You can still technically open and type in the chat while in-game but it won’t appear tell you tab out. When X-Split is fully closed it works fine.

I have reached out to FiveM regarding this and their statement was: “It is reading your chat as an overlay rather than ingame UI”. They say it’s being caused by X-Split and is not something they can fix on their end.

FiveM runs with Source SDK Base 2007 and is fully open source if that helps at all.

Any ideas on how to solve this would be great!

Hi! The mod may be having some compatibility issues with XSplit Broadcaster’s built-in HUD. Try disabling the in-game HUD from XSplit Broadcaster’s general settings, and see if it’s still having problems with FiveM’s chat.

That has been disabled for me the whole time, still not having any GUI type things showing up when x-split is open.

FiveM is known to have some issues with XSplit Broadcaster’s game capture source. Aside from disabling the in-game HUD, do you also have the game source disabled?


The workaround for streaming FiveM for XSplit Broadcaster has been to completely disable he game capture source, and add it as a screen capture.

We’ll also need to confirm if you’re on the current version of XSplit Broadcaster. What version number shows up if you go to the Help > About window?


Running the latest version, disabled game source and will try that out later today.

Following up still having an issue, when using Desktop capture the chat will not function.
Using screen capture allows it to work but does seem to have a delay and a little lag compared to what desktop capture gets.
Version; 4.1.2104.2317.
Game capture is fully disabled.

Following up again this issue is still occurring. Tried everything above but nothing seems to have fixed it.

Alright went through every setting and turns out this is caused and only occurs when GPU priority is turned on for XSplit. This is solved but there is for sure a root issue somewhere still.