Windows 11 Issue?

Microsoft’s Windows update gave me the green light to move to Windows 11 on my streaming computer today. I went ahead and pulled the trigger on the upgrade. Once my streaming computer was running Windows 11 I immediately start getting an error when I run XSplit Broadcaster. It says XSplit has encountered a problem and gave the following dump:

Detailed technical information follows:

Date and Time: 11/4/2021 10:01:29 PM -04:00
Machine Name: XXXXXXXXXXXX
Current User: XXXXXXXXXX
XSplit User:

Application Domain: XSplitRegSrc64.exe
Command Line: “C:\Program Files\XSplit\Broadcaster\XSplitRegSrc64.exe”
Parent Process: C:\Program Files\XSplit\Broadcaster\XSplit.Core.exe
Assembly Codebase: file:///C:/Program Files/XSplit/Broadcaster/XSplitRegSrc64.exe
Assembly Full Name: XSplitRegSrc64, Version=4.2.2109.2902, Culture=neutral, PublicKeyToken=null
Assembly Version: 4.2.2109.2902
Assembly Build Date: 9/29/2021 11:32:49 AM -04:00

Exception Source: mscorlib
Exception Type: System.Security.SecurityException
Exception Message: Requested registry access is not allowed.
Exception Target Site: ThrowSecurityException

---- Stack Trace ----
System.ThrowHelper.ThrowSecurityException(ExceptionResource resource)
XSplitRegSrc64.exe: N 00060
Microsoft.Win32.RegistryKey.OpenSubKey(String name, Boolean writable)
XSplitRegSrc64.exe: N 14174043
SplitMediaLabs.XSplitRegSrc.RegisterBroadcasterSource(Boolean x64)
XSplitRegSrc64.exe: N 00660

If I click ok at the error message it does run and appears to work but I get no sound when doing a test recording. So is there a Windows 11 update coming (to XSplit Broadcaster) or do I need to find a way to grant access to the registry (if that is even possible in Windows 11)?

Definitely need help :).

William Cochran

I’ve run into issues as well. I’m running in Windows 8 mode now and it seems to solve the issues. I was freezing up during broadcasts without a heavy load.