Xsplit not working in hangouts with firefox

Hi, I have the latest version of xsplit.

When I run google hangouts, I open Xsplit and it shows video as normal.

I open the video camera selection screen in hangout settings, and there’s actually two XSplit VCam’s in the list.

Both don’t do anything though other than show the XSplit logo.

Please, can I get some help?

Hello there, could you provide screenshot of what you see on VCam and screenshot of what you see on Google Meet?

Have you also tried it on a different browser like Chrome to see if it works?

Yes same problem in Chrome, here are some screenshots, you can see xsplit works by itself, chrome shows two vcams, one is broken and fails to start, the other just shows a blurry logo:

xsplit

Just to be sure that your VCam’s updated: What version number does it show if you go to Help > About inside the VCam window?

It says 2.0.2011.1701

That’s the updated version, although it should not be showing two VCam’s in the camera selection. Have you tried uninstalling then reinstalling VCam, then restarting the computer?

No I haven’t, that probably would work. However, I’m actually setting up a new computer right now. Thanks anyway for the help, I’m sure it will be fine on the new system.

Alright. Congrats on the new rig!