Xsplit version 3 and version 4

Is it possible to install this two versions separately so that I can test the version 4 while still be able to go back to using v3 if I find V4 not to my liking?

Hey @empyrite,

Switching between versions 3 and 4 is not possible. This is a requirement of XSplit to use the updated version as you boot up your Gamecaster as well as logging in to your XSplit account.

You can still use the previous version by going to this link: https://www.xsplit.com/gamecaster-legacy but do keep in mind that you have to uninstall your Gamecaster first to your current PC and install the legacy version.

Wow, that is kind of a bummer then…

because version 4 is so radically diffferent to v3 with some of the feature I am using kinda totally changed in 4.

:frowning:

Are there any particulars? The latest Gamecaster v4 is still in open Beta, so if you have any ideas on what you’d like to see, we welcome any new versions here: https://ideas-xgc.xsplit.com/

Recently we added NDI functionality on v4, which was present on 3.4.

My thoughts are all here. :slight_smile: